تا ۵۰٪ تخفیف قالب و افزونه جوملا در کانال تلگرام جومی

newyear96

گیر کردن و خطا در صفحه اول نصب جوملا 3 صفحه انتخاب زبان

آموزش رفع مشکل گیر کردن در صفحه اول نصب جوملا 2.5 (صفحه انتخاب زبان) با خطای Deprecated: preg_replace و Warning: session_start به صورت کاملا رایگان می آموزید.

جوملا 3.4 برای نصب در سرورهای لوکال قابلیت سازگاری با آخرین نسخه های منابع سیستمی را دارد اما منابعی وجود دارند که بیشترین سازگاری با جوملا را دارند. با توجه به تجربه ای که داشته ایم، در حال حاضر هم برای جوملا 2.5 و هم برای جوملا 3 بهترین سرور لوکال، سرور زمپ با نسخه 1.8.3 (Xamp Server 1.8.3)  است.

این آموزش فقط برای جوملا سری 3 طراحی شده است و برای رفع این مشکل در جوملا سری 2.5 اینجا کلیک کنید

در نصب بسته های نصب سریع قالب های جوملا 3 و همینطور بسته نصبی جوملا 3 بعضا در مرحله اول انتخاب زبان  مشابه خطاهای زیر را در همان مرحله ابتدایی نصب مشاهده می کنید. و نمی توانید مراحل نصب را ادامه دهید.

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /libraries/joomla/filter/input.php on line 652
Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /libraries/joomla/filter/input.php on line 654
Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /libraries/joomla/string/string.php on line 27
Deprecated: iconv_set_encoding(): Use of iconv.input_encoding is deprecated in /libraries/joomla/string/string.php on line 28
Deprecated: iconv_set_encoding(): Use of iconv.output_encoding is deprecated in /libraries/joomla/string/string.php on line 29
Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /libraries/joomla/string/string.php:27) in /libraries/joomla/session/session.php on line 654
Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /libraries/joomla/string/string.php:27) in /libraries/joomla/session/session.php on line 654

خطای نصب جوملا ۳

با جستجو در اینترنت راه حل های متعددی از جمله تغییر نسخه php، تغییر بعضی فایل ها و ... را مشاهده می کنید که در بسیاری موارد هم تضمین ۱۰۰٪ برای رفع مشکل از این راه حل ها وجود ندارد. گروه جومی همیشه تلاش کرده تا بهترین راه حل را در اختیار شما قرار دهد.

روش حل خطای به وجود آمده:

۱- ابتدا به سایت جوملای جهانی رفته و بسته به روز رسانی و آپدیت آخرین نسخه جوملا 3 را دریافت می کنیم. در روزی که این مقاله نوشته شده آخرین نسخه جوملا 3 نسخه 3.4.8 است. در نتیجه ابتدا به این لینک مراجعه می کنیم و بسته آپدیت با نام Joomla_3.6.4-Stable-Update_Package.zip را دانلود می کنیم.

۲- سپس وارد هاست و یا پوشه لوکالی که بسته نصبی قبلی در آن قرار داد شده شده و فایلی که دانلود کرده ایم را دقیقا در همان مسیر آپلود و بارگذاری می کنیم.

۳- سپس لازم است فایل را اکسترکت (از حالت زیپ) خارج کنیم. معمولا با کلیک راست بر روی فایل و گزینه اکسترکت این کار انجام می شود اما ممکن است در سیستم های عامل مختلف و هاست ها متفاوت باشد. نکته ای که باید توجه کنید این است که فایل ها دقیقا بر روی فایل های قبلی شما اکسترکت و جایگزین شوند.

۴- پس از این که مطمئن شدید فایل ها دقیقا بر روی بسته نصبی شما اکسترکت و جایگزین شدند سپس مجددا وارد مرحله نصب شوید و خواهید دید که مشکل برطرف شده و نصب به درستی انجام می شود.

نکته: پس از پایان نصب و ورود به بخش مدیریت جوملا برای بهینه سازی فایل ها و دیتا بیس بهتر است مراحل زیر را نیز انجام دهید.

۱- وارد بخش مدیریت جوملای خود شوید سپس مسیر زیر را طی کنید منوی افزونه ها / گزینه مدیریت افزونه ها / گزینه کاوش. در این صفحه ابتدا بر روی دکمه جستجو کلیک نمایید و اگر مواردی را به شما نشان داد همه موارد را تیک زده و انتخاب کنید و در نهایت بر روی گزینه نصب کلیک نمایید. اگر هم که موردی را پیدا نکرد و نمایش نداد نیاز به انجام کاری نیست.

۲- وارد بخش مدیریت جوملای خود شوید سپس مسیر زیر را طی کنید منوی افزونه ها / گزینه مدیریت افزونه ها / گزینه پایگاه داده. در این صفحه بر روی گزینه بازسازی کلیک نمایید.


در صورتی که هر گونه سوال و مشکلی در زمینه با این آموزش داشتید می توانید در طریق بخش نظرات با ما در میان بگذارید.

پیروز باشید

حمیدرضا ذوالفقار